Integrating BMS and VSA LiveConnect: Receiving OAuth connection error

Issue

When navigating to Admin > Service Desk > RMM Integration Settings > Live Connect tab in BMS, the following error is displayed: "Your VSA version does not support an OAuth Connection. VSA v9.X or later is required."

Cause

The VSA is likely not exposed via SSL with a valid certificate which is dictated by the VSA API and a prerequisite.

Resolution

Two things must be done:

  1. Install a valid SSL certificate on the VSA server.
  2. Use a URL with https:// (not http://) under Admin > Service Desk > RMM Integration Settings > General Settings > Server Address.

The prerequisite instructions can be found here:

For instructions on installing an SSL certificate, please see here:

Information on purchasing an SSL certificate can be found here: